Current Client Version: v0.10.4.0

Author Topic: Linux wallet install  (Read 63 times)

johncroc

  • Pole Dancer
  • *
  • Posts: 13
  • Karma: +2/-0
Linux wallet install
« on: June 07, 2018, 10:14:49 pm »
I am trying to install the wallet software on a new machine. 
I double-checked that I had all the dependencies installed (including qt5), then I did the "git clone", then from inside the "sexcoin" directory I did the ./autogen.sh and ./configure.  Everything seemed to go okay, but when I try to run "make" I get "make: *** No targets specified and no makefile found.  Stop."

I thought maybe I need to run it from the "sexcoin/src" directory...same thing (i.e. "make: *** No targets specified and no makefile found.  Stop.")

I'm not sure what to try next.  I remember installing 0.10.4 on the machine I'm decommissioning, but I don't remember having any trouble with it.

Any thoughts about what I've done wrong?

Thank you! 

johncroc

  • Pole Dancer
  • *
  • Posts: 13
  • Karma: +2/-0
Re: Linux wallet install
« Reply #1 on: June 07, 2018, 11:30:52 pm »
Nevermind.  I was wrong.  There WERE problems with the ./configure.  Namely, I have the wrong version of Berkley db installed.  I'll work on that and report back if I have further issues.


johncroc

  • Pole Dancer
  • *
  • Posts: 13
  • Karma: +2/-0
Re: Linux wallet install
« Reply #2 on: June 08, 2018, 12:04:44 am »
Fixed the bdb dependency, ./configure went well.  ran make and it seemed to go okay.  Tons of warnings but others have posted that's normal.  I expected to have a .sexcoin directory at the end of "make install" was surprised not to find one.  Did a "sudo find /  -name sexcoin-qt".  There isn't one.

Here is the last few lines of the output of "make":

In file included from /usr/include/x86_64-linux-gnu/qt5/QtGui/qwindowdefs.h:37:0,
                 from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/qwidget.h:37,
                 from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/qframe.h:37,
                 from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/qlabel.h:37,
                 from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/QLabel:1,
                 from qt/bitcoingui.h:14,
                 from qt/bitcoin.cpp:9:
/usr/include/x86_64-linux-gnu/qt5/QtCore/qglobal.h:1067:4: error: #error "You must build your code with position independent code if Qt was built with -reduce-relocations. " "Compile your code with -fPIC (-fPIE is not enough)."
 #  error "You must build your code with position independent code if Qt was built with -reduce-reloc
    ^
cc1plus: warning: unrecognized command line option ‘-Wno-self-assign’
Makefile:5554: recipe for target 'qt/qt_sexcoin_qt-bitcoin.o' failed
make[2]: *** [qt/qt_sexcoin_qt-bitcoin.o] Error 1
make[2]: Leaving directory '/home/john/sexcoin/src'
Makefile:6348: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/john/sexcoin/src'
Makefile:573: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

johncroc

  • Pole Dancer
  • *
  • Posts: 13
  • Karma: +2/-0
Re: Linux wallet install
« Reply #3 on: June 08, 2018, 10:52:30 pm »
After waiting to see if anyone had any thoughts on what might have gone wrong for me, I realized I had enough parts to build a "new" machine and install everything fresh.  On the fresh machine, I get a new error when running ./configure:
configure: error: Detected LibreSSL: This is NOT supported, and my break consensus compatibility!

Searching on the error, I find that a lot of people have gotten the same error when attempting to install various bitcoin-core-based wallets.  I tried all the remedies I could find but to no avail.  BTW, I don't have LibreSSL installed.  OpenSSL is installed and up-to-date.

I'm still stuck. If anyone has any thoughts I sure would appreciate the help.

John
« Last Edit: June 08, 2018, 11:40:21 pm by johncroc »

lavajumper

  • Administrator
  • Talk Show Host
  • *****
  • Posts: 265
  • Karma: +10/-0
Re: Linux wallet install
« Reply #4 on: June 15, 2018, 01:11:59 pm »
Hey Johncroc. I just saw this post. You're not the first one to hit that problem. There is a backward incompatibility with the SSL libs. I wanted to shoot you a quick post to let you know that you're not going insane. We first saw this creeping up with some work that wolf0 was doing on ArchLinux. I'll get some more detail written up about it and post it up here.

EDIT: a quick explanation is that the newer SSL libs are being misdetected as LibreSSL, which is really only the tip of the iceberg on this one.
« Last Edit: June 15, 2018, 01:13:54 pm by lavajumper »