Current Client Version: v0.10.4.0

Author Topic: Installing v0.10.4.0 on Ubuntu Xenial 16.04  (Read 393 times)

ac0rnsoup

  • Virgin
  • *
  • Posts: 7
  • Karma: +0/-0
Installing v0.10.4.0 on Ubuntu Xenial 16.04
« on: July 04, 2017, 05:35:00 pm »
Abbreviated instructions with no explanations for those that just want to get it going with minimal reading and no decision making.

install dependencies
Code: [Select]
sudo apt-get install build-essential libtool autotools-dev autoconf pkg-config libssl-dev git libboost-all-dev libminiupnpc-dev software-properties-common bsdmainutils

install db4.8 from a bitcoin PPA
Code: [Select]
sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update
sudo apt-get install libdb4.8-dev libdb4.8++-dev

install GUI dependencies
Code: [Select]
sudo apt-get install libqt4-dev libprotobuf-dev protobuf-compiler

clone the source code
Code: [Select]
git clone https://github.com/sexcoin-project/sexcoin.git

build and install it
Code: [Select]
./autogen.sh
./configure
make
sudo make install

LMK if there are any errors or if you have issues.

EDIT: add two dependencies missing in docker maintained Ubuntu image
« Last Edit: July 05, 2017, 04:41:26 pm by ac0rnsoup »

lavajumper

  • Administrator
  • Talk Show Host
  • *****
  • Posts: 252
  • Karma: +10/-0
Re: Installing v0.10.4.0 on Ubuntu Xenial 16.04
« Reply #1 on: July 28, 2017, 04:06:47 am »
Just did this on a 16.04 machine... went without a hitch!

Nice.

+1

johncroc

  • Virgin
  • *
  • Posts: 9
  • Karma: +2/-0
Re: Installing v0.10.4.0 on Ubuntu Xenial 16.04
« Reply #2 on: July 29, 2017, 11:28:43 pm »
Took me a couple tries to figure out how to start the wallet gui ("sexcoin-qt" from a terminal prompt).  Other than that, smooth sailing!

Thank you!